User Tools

Site Tools


readme:knownissues:java

DK for Java

Documentation | Known issues | DK for Java

Compatibility

DK for Java is built with Java 8.

Compatibility Java 8 Java 9 Java 10 Java 11 Java 12 Java 13 Java 14 Java 15
General DK compatibility + + + + + + + +
Setup + +- + + + + + +
Running app compiled with Java 8 + + + + + + + +
Compiling new apps + + + - + + + +

Java 8

  • No known issues.

Java 9

  • Setup (minor)
    If run under Java 9, display sAPP_NAME, APP_VER instead of actual numbers.

Java 10

  • No known issues.

Java 11

  • Compiling new apps
    We are aware of the problems with the compilation of some API including TGIS_LayerVector.CreateShape. \\It is due to the bug in Java itself related to metaclass support. An application compiled with other Java version (e.g with Java 8) works properly.

Java 12

  • No known issues.

Java 13

  • No known issues.

Java 14

  • No known issues.

Java 15

  • No known issues.

WMS, WMTF and WFS

Some governmental web services of Nederlands do not work. The problem is that those services use root certificate Staat der Nederlanden EV Root CA which was added in Java 15. In previous versions, this certificate must be installed manually using Java's keytool.

2021/09/24 08:50

Page Tools